Commit e7d259f0 authored by Thomas Bella's avatar Thomas Bella

Add initial h3 support. Thanks to David Schinazi

parent 3e20b04f
......@@ -13,7 +13,7 @@ chrome.runtime.onMessage.addListener((message, sender, sendResponse) => {
// As of Chrome 66, only QUIC/39 is supported. chrome://net-internals/#quic --> Supported Versions QUIC_VERSION_39
title = 'HTTP/2 + QUIC/39'
icon = 'hq'
} else if (message.includes("quic")) {
} else if (message.includes("quic") || message.startsWith("h3")) {
// Chrome 68+ changed the content of the field which includes the used version
// Example value: http/2+quic/43
title = message.replace("+", " + ").replace("http/", "HTTP/").replace("quic/", "QUIC/")
......
{
"manifest_version": 2,
"name": "Protocol Indicator",
"version": "1.1",
"version": "1.2",
"description": "HTTP/2 and QUIC protocol indicator",
"minimum_chrome_version": "57",
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment